Unverified Commit d270463d authored by Maarten de Waard's avatar Maarten de Waard 🤘🏻
Browse files

use middleman-ogp version that dynamically sets locale and extends overrides to twitter namespace

parent bcba5419
......@@ -29,4 +29,10 @@ gem 'therubyracer'
# Html parsing
gem 'ruby-cheerio'
gem 'middleman-ogp', '1.2'
# Wait for these PRs to be merged:
# https://github.com/ngs/middleman-ogp/pull/16
# https://github.com/ngs/middleman-ogp/pull/17
# gem 'middleman-ogp', '1.4'
gem 'middleman-ogp',
:git => 'https://github.com/greenhost/middleman-ogp',
:ref => 'override-all-namespaces-and-add-locale'
GIT
remote: https://github.com/greenhost/middleman-ogp
revision: 203170f04ffc6350d6913c6545e760d2eefc3a6c
ref: override-all-namespaces-and-add-locale
specs:
middleman-ogp (1.4.0)
middleman-core (>= 4.0)
GIT
remote: https://github.com/middleman/middleman
revision: 5426f9dff9094a5290dd7f70f006963ca0c8cec7
......@@ -85,8 +93,6 @@ GEM
em-websocket (~> 0.5.1)
middleman-core (>= 3.3)
rack-livereload (~> 0.3.15)
middleman-ogp (1.2.0)
middleman-core (>= 3.2)
middleman-sprockets (4.1.1)
middleman-core (~> 4.0)
sprockets (>= 3.0)
......@@ -149,7 +155,7 @@ DEPENDENCIES
middleman!
middleman-autoprefixer (~> 2.7)
middleman-livereload
middleman-ogp (= 1.2)
middleman-ogp!
middleman-sprockets
rails-assets-bootstrap!
rails-assets-jquery!
......@@ -162,4 +168,4 @@ DEPENDENCIES
therubyracer
BUNDLED WITH
1.16.5
1.17.3
......@@ -212,6 +212,7 @@ end
# Activate OGP plugin. Note that this does not have i18n support, so that is
# added manually in main.slim
activate :ogp do |ogp|
ogp.auto = ['title', 'description', 'locale', 'url']
# Default opengraph data (sets image to Totem logo)
ogp.namespaces = {
og: data.ogp.og,
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment